Начало > Linux, OpenSuse > OpenSuse 12.1 и php 5.2.17

OpenSuse 12.1 и php 5.2.17

Компилиране на php 5.2.17.

./configure \
–prefix=/usr/local/php5 \
–with-apxs2=/usr/sbin/apxs2 \
–with-libdir=lib64 \
–enable-bcmath \
–enable-calendar \
–with-curl \
–enable-exif \
–enable-ftp \
–with-gd \
–with-jpeg-dir=/usr/local \
–with-png-dir=/usr \
–with-xpm-dir=/usr/X11R6 \
–with-gettext \
–with-iconv \
–enable-mbstring \
–enable-mbregex \
–with-mcrypt \
–with-mhash \
–enable-magic-quotes \
–with-mysqli \
–with-mysql \
–with-openssl \
–enable-discard-path \
–with-pear \
–enable-safe-mode \
–enable-sockets \
–with-ttf \
–with-freetype-dir=/usr \
–enable-gd-native-ttf \
–enable-wddx \
–with-xmlrpc \
–with-zlib \
–with-imap \
–with-kerberos \
–with-imap-ssl \
–enable-soap

за да не ни плюе с грешки:

zypper in libxml2-devel libcurl-devel libjpeg-devel libpng-devel libXpm-devel freetype-devel libc-client-devel install mhash mhash-devel libmcrypt-devel libtool-ltdl-devel

zypper in xorg-x11-libXpm-devel

много е вероятно ако в configure -то е зададено да се ползва support на imap да се появят следните грешки:

utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log

Решение:

zypper in libc-client2007e_suse
zypper in imap-devel

configure: error: Kerberos libraries not found

Решение:


zypper in krb5
zypper in krb5-client
zypper in krb5-devel

и най-любимата ми:

checking whether build with IMAP works… no
configure: error: build test failed. Please check the config.log for details.

в config.log има записано нещо подобно на:

/usr/lib/libc-client.so: undefined reference to `pam_end’
/usr/lib/libc-client.so: undefined reference to `pam_authenticate’
/usr/lib/libc-client.so: undefined reference to `pam_setcred’
/usr/lib/libc-client.so: undefined reference to `pam_set_item’
/usr/lib/libc-client.so: undefined reference to `pam_acct_mgmt’
/usr/lib/libc-client.so: undefined reference to `pam_start’
collect2: ld returned 1 exit status
configure: failed program was:
#line 47384 „configure“
#include „confdefs.h“

void mm_log(void){}
void mm_dlog(void){}

Решение:

zypper in pam-devel

Categories: Linux, OpenSuse Tags:
  1. 11 септември, 2012 в 15:04 | #1

    Няма ли излезли официални пакети на PHP v5.3 за suse?

  2. 13 септември, 2012 в 08:49 | #2

    Официални пакети, че има-има :)
    Причините са две:

    1.Спортна злоба :)
    2.mail header patch

  1. 0 trackbacks