Архив

Архив за ‘Linux’ категория

Инсталиране на Skype – OpenSuse 11.3 64-bit

26 февруари, 2011 1 коментар

За да не гърми с грешки Skype се инсталира по следният начин:
1. Влиза се под конзола
su
Password:
след това се пише следното:

zypper in libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bit

ако пита нещо се отговаря с y
след това се инсталира skype
rpm -i skype-2.1.0.81-suse.i586.rpm

Това е.

Categories: Linux, OpenSuse Tags:

Филми под Linux (OpenSuse 11.1 64-bit)

27 декември, 2009 Няма коментари

От няколко месеца насам съм принуден да ползвам Линукс,като десктоп.Ползвам OpenSuse 11.1 64-bit.В началото натоварих една камара софтуер,една част от който ползвам всеки ден и друг,който и хал-хабер си нямам как се ползва 🙂 . После намерих програмите които ми трябват за ежедневна употреба,от рода на Packet Tracer и т.н. .И така до днеска,когато се сетих,че искам да гледам и филми.В началото ми се виждаше „Мисията невъзможна“ но се оказа,че има съвесем елементарно решение.И то се казва XINE,и се прави с т.нар. 1-click install.След около 10-15 минути ръчкане попаднах на packman.links2linux.org .И там намерих всичко,което ми беше нужно кодеци и player.Ето и двата директни линка:
Кодеци и библиотеки за Xine
Самият XINE
Избирате версията на дистрото с което сте маркирате го после се набирате на бутончето 1-click install,и готово.
BTW гледам има и разни скинове,но по принцип не съм им особен почитател,но за които има интерес хората и това са предвидили.
Само да добавя още нещо има вероятност субтитрите да излизат на маймуница.Проблемът се решава много лесно.
Стартирате XINE,десен бутон върху прозореца,излиза едно падащо меню,избирате Settings->Setup…->табчето gui->Падащо меню с надпис Configuration experience level->избрате Advanced->набирате се на бутона Apply
После отивате на табчето subtitles->има един прозорец с име encoding of the subtitles->трием това което пише в него и въвеждаме следното windows-1251 пак бутона Apply след това Close и вече всичко трябва да е ОК.
Успех и приятно гледане 🙂

Categories: Linux, OpenSuse Tags:

alien за linux

21 октомври, 2009 Няма коментари

Онзи ден ми попдана една малка,но за сметка на това много полезна програмка- alien .

Програмката представлява конвертор,който конвертира пакети от една дистрибуция за друга.Например от .deb за Дебиан в .rpm за openSUSE или Red hat.Поддържа следните формато .deb, .rpm,.tgz.,.slp,.pkg

Програмата работи в конзолен режим.Ето и част от синтаксиса и:

alien –to-deb package.rpm

създава .deb пакет от .rpm

Не знам до каква степен е съвместима с повечето пакети,но засега не съм имал проблеми.Дано и при Вас да е така 🙂

За повече информация относно синтаксиса и програмата,можете да посетите:

http://linux.die.net/man/1/alien

Categories: Linux Tags:

Странни хардуерни проблеми

20 октомври, 2009 Няма коментари

Преди около месец изпуснах лаптопа си при което той,малко пострада.Малко в смисаъл откачи му се харда,но с дружни усилия успяхме да го закачим и наместим с Роси.Но малко след това започна да прави други ядове.При зареждане на Вистата изпадаше в някакви странни цикли,които продължаваха до 10-15 преди да се стратира ОС.Реших,че трябва да я преинсталирам.Влязох във Вендор Диагностик режим зададох да се преиснталира всичко и да се върнат фабричните настройки.И тука започнаха ядовете.Лаптопа по средата на инсталацията просто изгасваше и точка.Чудих се какво да правя и реших да му инсталирам Linux openSuse 11.1.За мое най-голямо учудване дистрото се инсталира без проблеми.Имах доста проблеми с флаш но ги пооправих в последствие.Най-странното беше,че реших да инсталирам XEN,и да направя Windows virtual-na машина.XEN се инсталира,но за мое най-голямо учудване при зареждане XEN ядрото Лаптопа пак започна да гасне.От странно по-странно,не знам на какво се дължи,някой от драйверите в Windows,или XEN прави прекъсване към някой дефектирал от падането компонент ли,та сега са ме налегнали странни мисли защо става така.А на сервиз не искам да го водя,че пари залудо не ми се дават.Някой ако има идеи или опит с подобна дивотия,моля да ги сподели. 🙂

Categories: Linux, OpenSuse Tags:

SuseLinux 11.0 и решения на Wireless проблемчета

2 август, 2008 Няма коментари

Този път впечетленията са повече от добри.Разпозна почти всичкият хардуер на лаптопа АСЕР,travel mate 5515 wlmi.Справи се с целият хардуер на домашният  компютър,включително и с монитора му.Но както винаги и този път не мина без изненади,а те разбира се бяха в така любимото ми място от хардуера наречено Wireless ;).В самото начало се зарадвах,че чипа се разпозна още при самата инсталция и се зареди модул наречен ath5k,но малко след това се започна ходенето по мъките.

При написване на dmesg | grep ath се получаваше следният резултат:

ath5k_pci 0000:05:00.0: registered as ‘phy0’
ath5k phy0: failed to resume the MAC Chip
ath5k_pci: probe of 0000:05:00.0 failed with error -5

След доста гуглене попаднах на информация,от която разбрах,че има проблем с  wireless чипa Atheros5007.Разпознавал се грешно от модула ath5k.И трябвало да бъде сложен в blacklista.Речено сторено.Отидох до /etc/modprobe.d/

Oтворих файла blacklist и в него добавих следният рeд:

blacklist ath5k

След това се пробвах да изтегля:madwifi-ng-r2756+ar5007.tar.gz

Но за мое най-голямо учудване сайта madwifi.org не работеше 🙂

Тогава минах на другият вариянт с ndiswrapper,този път го инсталирах директно от DVD то с инсталацията.

Последва познатото:

#ndiswrapper -i net5211.inf

#modprobe ndiswrapper

След това рестарт и wireless-a вече даваше достъп до настройките в YAST.

След това инсталирах и wpa_supplicant от  инсталционното DVD.

Дадох му е един ребут.После си донастроих картата и в момента тези редове излизат благодарение на Wirelessa.

Има и още едно решение с madwifi,но не знам дали ще работи при вас намира се на следният адрес:

http://lizards.opensuse.org/2008/07/14/atheros-ar-5007-eg-on-opensuse-110/

Categories: Linux, OpenSuse Tags:

Кирилица и „OpenSuse“

22 април, 2008 Няма коментари

Аз лично си настроих кирилицата по следният начин.Start Buton->Configure Desktop->Regional & Accessibility->Keyboard Layout->Сложих отметка на Enable keyboard layout->отбелязах Bulgaria->Add>>->долу на layout variant: ->дадох на phonetic става след като се маркира Bulgaria BG->Apply.После отидох на табчето Xkb Options->сложих отметка на Enable Xkb Options после си избрах Left Ctrl key changes layouts->на табчето Switching Options сложих отметки на Show indicator for single layout и на Show Country flag.Сега вече мога да пиша и на фонетична кирилица.

Categories: Linux, OpenSuse, Софтуер Tags:

Wirelessa най-после проработи под Suse-то

След 2 дневно постоянно ръчкане Atheros Wireless-a,най-после сработи.Появи се като wlan0.В началото така и не разбрах какво го накара да проработи бях свалил и компилирал madwifi драйвери.С тях не стана.После реших да пробвам с ndiswrapper.Изтеглих от сайта на Acer драйвери за XP.По-време на самата инсталация излизаха някакви warnings,но се получи.При следващият ми опит за повторна инсталация suse-то изплю,че драйвера е already installed.Зададох му през аплета за настройка на мрежа да ми пусне интерфейса при стартиране.И след рестарта се получи.При написване на ifconfig излизаше и wlan0.После стана малко странно,че след изключване на лаптопа,интерфейса беше изчезнал.Поровичках го пак зададох му пак да се стартира по време на зареждане на ОС и след рестарта вече работеше.Сега дойде друг проблем.Установяване на връзка с рутера,който използва WPA2-personal,аутентификация.Пробвах с едно аплетче да го настроя – wifi-radar,но не би.Не ще и това е!Явно ще трябва да се четът man страниците на iwconfig,и wiki съдържанието на opensuse.org.Другият проблем който изникна,че нямам кирилица в suse-то.В момента не ми се занимаваше повече та пак под Вистата.

Ето и техническата част на инсталацията:

Изтеглих последната версия на ndiswrapper.Компилирах я.След това разархивирах драйвера за atherosа.Избрах този който беше за 64 битово XP.

#ndiswrapper -i net5211.inf

#modprobe ndiswrapper

по някое време имах и спомени,че писах

#modprobe ndiswrapper -m

нямам идея какво прави тази опция и дали е оказала влияние.Беше дословно преписана от wiki-то на suse-то.
След това зададох следното нещо в прозореца за настройка на мрежата:Най-важното нещо на Modulname да се зададе ndiswrapper.


Инсталирах wifi-radar.Видя мрежата,но явно не успях да му задам правилните параметри за аутентификация и връзка не се получи ;(.За момента и на това съм доволен.Щом стигнах до тук ще намеря начин и да се свържа с рутера 🙂
Да не забравя цялата тази дивотия е правих с root права,то май иначе няма да стане и да иска човек ;–)